Page 1 of 1

Posted: Thu May 15, 2014 12:57 pm
by JD
Is there a method for checking to make sure the dataset is in the Report Management System repository before running RM80004?

Posted: Thu May 15, 2014 1:43 pm
by NicC
How about a title for your topic?

Posted: Thu May 15, 2014 1:51 pm
by JD
Ran RM80004 and got the message “Dataset Not Found”.

Posted: Thu May 15, 2014 11:19 pm
by DikDude
It you want to get help, you have to do a better job of posting your problem . . .

We need to see the problem run as well as the diagnostics generated by the attempt.

You should not start a topic without a subject. When you post yours, we will update your subject.

Posted: Mon May 19, 2014 11:03 am
by JD
The problem was when I ran a job using program RM80004 (a Report Management System program that distributes a selected set of reports using the instruction sets produced by RMS/DD), I got this message "Dataset Not Found" knowing that the dataset was sent to the RMS report repository but did appear in the RMS report repository shortly after the job run. Per my analysis the dataset was probably not yet in the RMS report repository at the precise moment program RM80004 was looking to it. Now I'm looking for a solution that will create a JCL to check and ensure that the dataset is in the RMS report repository before I run the program RM80004. According to the RMS reference manual I have to use the checkpoint dataset to check for the desired dataset but I have no idea how to use it. No sample JCL is given. It also states that if the checkpoint is not satisfied the system will wait 2 minutes and check again. It will continue checking until the dataset is found.

Posted: Mon May 19, 2014 1:09 pm
by NicC
Well, unless someone knows this particular software package and has used that particular facility and no one in your shop, including the system people, knows then you, or the rmds support should contact the vendor for example code to do what you want. I'm afraid that that is all that I can suggest.